FAQs: Operating Systems





What are the system requirements for the Babylon client?

Windows XP
Windows Vista
Windows 7

What are the system requirements for the Babylon application server?

Windows 2000 Server and Windows 2003 Server.
In addition, the server also requires: Microsoft Internet Information Server (IIS) with ISAPI support; Microsoft Internet Explorer Version 5.0 and above; a local NTFS volume. Administrative user rights are required for server installation.

Can Babylon Corporate Edition client run on platforms other than Windows?

The Babylon client is currently supported on Windows XP and Windows Vista.

Babylon now has a Mac version, but it is unrelated to the Corporate Edition. The Mac version can be deployed on individual desktops within an organization, under the responsibility of the organization of the system administration.

Babylon continually evaluates the market and may develop products for other platforms if there is sufficient demand for Babylon products for operating systems such as UNIX and Linux, or for small personal devices such as PDAs and mobile phones.